summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2016-08-29 18:03:25 (GMT)
committerdoko@ubuntu.com <doko@ubuntu.com>2016-08-29 18:03:25 (GMT)
commit75b1cb10b53d55cf51f32049ba76a6be82b4f6bb (patch)
treee6dda2f4abd14c032c36e67d9f47b16a013c2309 /configure.ac
parent4e1de16f88cd8b99b2d154e647b63f2f6f8b58ae (diff)
downloadcpython-75b1cb10b53d55cf51f32049ba76a6be82b4f6bb.zip
cpython-75b1cb10b53d55cf51f32049ba76a6be82b4f6bb.tar.gz
cpython-75b1cb10b53d55cf51f32049ba76a6be82b4f6bb.tar.bz2
- Issue #23968, keep platform_triplet and multiarch macros in sync
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64c844d..2e0cb39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -882,6 +882,8 @@ if test x$PLATFORM_TRIPLET != x && test x$MULTIARCH != x; then
if test x$PLATFORM_TRIPLET != x$MULTIARCH; then
AC_MSG_ERROR([internal configure error for the platform triplet, please file a bug report])
fi
+elif test x$PLATFORM_TRIPLET != x && test x$MULTIARCH = x; then
+ MULTIARCH=$PLATFORM_TRIPLET
fi
if test x$PLATFORM_TRIPLET = x; then
PLATDIR=plat-$MACHDEP