summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLivius <egyszeregy@freemail.hu>2021-09-13 12:37:38 (GMT)
committerGitHub <noreply@github.com>2021-09-13 12:37:38 (GMT)
commit85a4748118c3793be7047ecbcbfc79dd07cb2a75 (patch)
tree8faca8b6e772af6312db9daa26f4d89b1e29a3bd /configure.ac
parent3e19409d6443c66a6a7d62f58b2bb4e8330e56c4 (diff)
downloadcpython-85a4748118c3793be7047ecbcbfc79dd07cb2a75.zip
cpython-85a4748118c3793be7047ecbcbfc79dd07cb2a75.tar.gz
cpython-85a4748118c3793be7047ecbcbfc79dd07cb2a75.tar.bz2
bpo-21302: Add clock_nanosleep() implementation for time.sleep() (GH-28111)
In Unix operating systems, time.sleep() now uses the clock_nanosleep() function, if available, which allows to sleep for an interval specified with nanosecond precision. Co-authored-by: Victor Stinner <vstinner@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bcb2054..4a0694c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4115,6 +4115,12 @@ AC_CHECK_FUNCS(clock_settime, [], [
])
])
+AC_CHECK_FUNCS(clock_nanosleep, [], [
+ AC_CHECK_LIB(rt, clock_nanosleep, [
+ AC_DEFINE(HAVE_CLOCK_NANOSLEEP, 1)
+ ])
+])
+
AC_MSG_CHECKING(for major, minor, and makedev)
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
#if defined(MAJOR_IN_MKDEV)