summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2012-12-12 12:10:21 (GMT)
committerChristian Heimes <christian@cheimes.de>2012-12-12 12:10:21 (GMT)
commit954ac03a44efd352ca06a85caf2e2c04e49b3ede (patch)
treef3929c05ba63425b6708a4dba404754af868baaf /configure.ac
parentd783261e99ebb5b3f305c3261a5b6ebf69de95db (diff)
downloadcpython-954ac03a44efd352ca06a85caf2e2c04e49b3ede.zip
cpython-954ac03a44efd352ca06a85caf2e2c04e49b3ede.tar.gz
cpython-954ac03a44efd352ca06a85caf2e2c04e49b3ede.tar.bz2
Cross compiling needs host and build settings. configure no longer
creates a broken PYTHON_FOR_BUILD variable when --build is missing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2738703..ef58a9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,6 +67,8 @@ if test "$cross_compiling" = yes; then
AC_MSG_RESULT($interp)
PYTHON_FOR_BUILD="_PYTHON_PROJECT_BASE=$srcdir"' _PYTHON_HOST_PLATFORM=$(_PYTHON_HOST_PLATFORM) PYTHONPATH=$(srcdir)/Lib:$(srcdir)/Lib/plat-$(MACHDEP) '$interp
fi
+elif test "$cross_compiling" = maybe; then
+ AC_MSG_ERROR([Cross compiling required --host=HOST-TUPLE and --build=ARCH])
else
PYTHON_FOR_BUILD='./$(BUILDPYTHON) -E'
fi