summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2017-03-04 06:05:06 (GMT)
committerGitHub <noreply@github.com>2017-03-04 06:05:06 (GMT)
commit95c50e5aed9e5683676e18349dd94b11901a66b3 (patch)
treed0e57a3b64c496f48ba99eb12149b4393b082570 /configure.ac
parent793f822068335cff68f25304a915c726f3f3a599 (diff)
downloadcpython-95c50e5aed9e5683676e18349dd94b11901a66b3.zip
cpython-95c50e5aed9e5683676e18349dd94b11901a66b3.tar.gz
cpython-95c50e5aed9e5683676e18349dd94b11901a66b3.tar.bz2
[3.6] bpo-27593: Get SCM build info from git instead of hg. (#446) (#454)
* bpo-27593: Get SCM build info from git instead of hg. (#446) sys.version and the platform module python_build(), python_branch(), and python_revision() functions now use git information rather than hg when building from a repo. Based on original patches by Brett Cannon and Steve Dower. (cherry picked from commit 5c4b0d063aba0a68c325073f5f312a2c9f40d178)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 13 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 64f12f2..f00a2a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,25 +25,25 @@ else
BASECPPFLAGS=""
fi
-AC_SUBST(HGVERSION)
-AC_SUBST(HGTAG)
-AC_SUBST(HGBRANCH)
+AC_SUBST(GITVERSION)
+AC_SUBST(GITTAG)
+AC_SUBST(GITBRANCH)
-if test -e $srcdir/.hg/dirstate
+if test -e $srcdir/.git/HEAD
then
-AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+AC_CHECK_PROG(HAS_GIT, git, found, not-found)
else
-HAS_HG=no-repository
+HAS_GIT=no-repository
fi
-if test $HAS_HG = found
+if test $HAS_GIT = found
then
- HGVERSION="hg id -i \$(srcdir)"
- HGTAG="hg id -t \$(srcdir)"
- HGBRANCH="hg id -b \$(srcdir)"
+ GITVERSION="git -C \$(srcdir) rev-parse HEAD"
+ GITTAG="git -C \$(srcdir) name-rev --tags --name-only HEAD"
+ GITBRANCH="git -C \$(srcdir) name-rev --name-only HEAD"
else
- HGVERSION=""
- HGTAG=""
- HGBRANCH=""
+ GITVERSION=""
+ GITTAG=""
+ GITBRANCH=""
fi
AC_CONFIG_SRCDIR([Include/object.h])