summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2012-03-15 19:42:23 (GMT)
committerMatthias Klose <doko@ubuntu.com>2012-03-15 19:42:23 (GMT)
commit9635013a8fb68c044ea2cae2ec344b3940c188b2 (patch)
treea47bfbe88808d6ecf749cd3acdd46bdc9347389a /configure.ac
parentb17289e199da24ca08752553e94837456b6c5df5 (diff)
downloadcpython-9635013a8fb68c044ea2cae2ec344b3940c188b2.zip
cpython-9635013a8fb68c044ea2cae2ec344b3940c188b2.tar.gz
cpython-9635013a8fb68c044ea2cae2ec344b3940c188b2.tar.bz2
- Issue #14324: Fix configure tests for cross builds.
when configured with --(en|dis)able-ipv6 for cross builds, don't fail the configury due to the missing buggy-getaddrinfo check.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1ae79cc..6db4f3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3009,7 +3009,12 @@ int main()
]]])],
[ac_cv_buggy_getaddrinfo=no],
[ac_cv_buggy_getaddrinfo=yes],
-[ac_cv_buggy_getaddrinfo=yes]))
+[
+if test "${enable_ipv6+set}" = set; then
+ ac_cv_buggy_getaddrinfo="no -- configured with --(en|dis)able-ipv6"
+else
+ ac_cv_buggy_getaddrinfo=yes
+fi]))
fi
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)