summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2016-09-07 18:06:17 (GMT)
committerBenjamin Peterson <benjamin@python.org>2016-09-07 18:06:17 (GMT)
commita9296e7f3be4d6c22271b25c86467ff867c63bbb (patch)
treeb5f2db17acd82ff33b61cb25d069e12b01f23516 /configure.ac
parent2195d537b37c1bc12759c6ed85aba2846e7ab574 (diff)
downloadcpython-a9296e7f3be4d6c22271b25c86467ff867c63bbb.zip
cpython-a9296e7f3be4d6c22271b25c86467ff867c63bbb.tar.gz
cpython-a9296e7f3be4d6c22271b25c86467ff867c63bbb.tar.bz2
require C99 bool
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b511a79..d89ebef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2128,17 +2128,7 @@ if test "$have_long_double" = yes ; then
AC_CHECK_SIZEOF(long double, 16)
fi
-
-AC_MSG_CHECKING(for _Bool support)
-have_c99_bool=no
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[_Bool x; x = (_Bool)0;]])],[
- AC_DEFINE(HAVE_C99_BOOL, 1, [Define this if you have the type _Bool.])
- have_c99_bool=yes
-],[])
-AC_MSG_RESULT($have_c99_bool)
-if test "$have_c99_bool" = yes ; then
AC_CHECK_SIZEOF(_Bool, 1)
-fi
AC_CHECK_SIZEOF(off_t, [], [
#ifdef HAVE_SYS_TYPES_H