summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDong-hee Na <donghee.na@python.org>2023-01-24 10:22:00 (GMT)
committerGitHub <noreply@github.com>2023-01-24 10:22:00 (GMT)
commita958e7d35af191c354a3e89a1236e830b1e46029 (patch)
tree1c82564f35e46da2c3d365ccd060da3203232283 /configure.ac
parent8c183cddd3d0031c6d397738f73c20ee6bf61ce8 (diff)
downloadcpython-a958e7d35af191c354a3e89a1236e830b1e46029.zip
cpython-a958e7d35af191c354a3e89a1236e830b1e46029.tar.gz
cpython-a958e7d35af191c354a3e89a1236e830b1e46029.tar.bz2
gh-101278: Drop -gdwarf-4 flag from the BOLT build (gh-101280)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 12249b2..5eee458 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1952,9 +1952,6 @@ if test "$Py_BOLT" = 'true' ; then
CFLAGS_NODIST="$CFLAGS_NODIST -fno-pie"
# We want to add these no-pie flags to linking executables but not shared libraries:
LINKCC="$LINKCC -fno-pie -no-pie"
- # Designate the DWARF version into 4 since the LLVM-BOLT does not support DWARF5 yet.
- CFLAGS="$CFLAGS -gdwarf-4"
- LDFLAGS="$LDFLAGS -gdwarf-4"
AC_SUBST(LLVM_BOLT)
AC_PATH_TOOL(LLVM_BOLT, llvm-bolt, '', ${llvm_path})
if test -n "${LLVM_BOLT}" -a -x "${LLVM_BOLT}"