summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDonghee Na <donghee.na@python.org>2024-09-24 01:28:59 (GMT)
committerGitHub <noreply@github.com>2024-09-24 01:28:59 (GMT)
commitad7c7785461fffba04f5a36cd6d062e92b0fda16 (patch)
tree4e4da0559c1b120872095862f11ca915fac0d405 /configure.ac
parentbe76e3f26e0b907f711497d006b8b83bff04c036 (diff)
downloadcpython-ad7c7785461fffba04f5a36cd6d062e92b0fda16.zip
cpython-ad7c7785461fffba04f5a36cd6d062e92b0fda16.tar.gz
cpython-ad7c7785461fffba04f5a36cd6d062e92b0fda16.tar.bz2
gh-123990: Good bye WITH_FREELISTS macro (gh-124358)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 0 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index c4df726..1864e94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4977,24 +4977,6 @@ then
fi
AC_MSG_RESULT([$with_pymalloc])
-# Check whether objects such as float, tuple and dict are using
-# freelists to optimization memory allocation.
-AC_MSG_CHECKING([for --with-freelists])
-AC_ARG_WITH(
- [freelists],
- [AS_HELP_STRING([--with-freelists], [enable object freelists (default is yes)])])
-
-if test -z "$with_freelists"
-then
- with_freelists="yes"
-fi
-if test "$with_freelists" != "no"
-then
- AC_DEFINE([WITH_FREELISTS], [1],
- [Define if you want to compile in object freelists optimization])
-fi
-AC_MSG_RESULT([$with_freelists])
-
# Check for --with-c-locale-coercion
AC_MSG_CHECKING([for --with-c-locale-coercion])
AC_ARG_WITH(