summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2012-12-02 13:20:22 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2012-12-02 13:20:22 (GMT)
commitce31f66a6d23a5df75eb692c2991e7602b2b6571 (patch)
tree7acb60d9b9c765d1c7910a4958ac6577786a9de6 /configure.ac
parent43fb54cd4f27f9c27f114d7b6fb2e04b35441a92 (diff)
downloadcpython-ce31f66a6d23a5df75eb692c2991e7602b2b6571.zip
cpython-ce31f66a6d23a5df75eb692c2991e7602b2b6571.tar.gz
cpython-ce31f66a6d23a5df75eb692c2991e7602b2b6571.tar.bz2
Issue 10052: fix failed uint32_t / uint64_t / int32_t / int64_t detection on some platforms.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97332af..ccb42d4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1469,10 +1469,30 @@ AC_TYPE_PID_T
AC_DEFINE_UNQUOTED([RETSIGTYPE],[void],[assume C89 semantics that RETSIGTYPE is always void])
AC_TYPE_SIZE_T
AC_TYPE_UID_T
+
+# There are two separate checks for each of the exact-width integer types we
+# need. First we check whether the type is available using the usual
+# AC_CHECK_TYPE macro with the default includes (which includes <inttypes.h>
+# and <stdint.h> where available). We then also use the special type checks of
+# the form AC_TYPE_UINT32_T, which in the case that uint32_t is not available
+# directly, #define's uint32_t to be a suitable type.
+
+AC_CHECK_TYPE(uint32_t,
+ AC_DEFINE(HAVE_UINT32_T, 1, [Define if your compiler provides uint32_t.]),,)
AC_TYPE_UINT32_T
+
+AC_CHECK_TYPE(uint64_t,
+ AC_DEFINE(HAVE_UINT64_T, 1, [Define if your compiler provides uint64_t.]),,)
AC_TYPE_UINT64_T
+
+AC_CHECK_TYPE(int32_t,
+ AC_DEFINE(HAVE_INT32_T, 1, [Define if your compiler provides int32_t.]),,)
AC_TYPE_INT32_T
+
+AC_CHECK_TYPE(int64_t,
+ AC_DEFINE(HAVE_INT64_T, 1, [Define if your compiler provides int64_t.]),,)
AC_TYPE_INT64_T
+
AC_CHECK_TYPE(ssize_t,
AC_DEFINE(HAVE_SSIZE_T, 1, [Define if your compiler provides ssize_t]),,)