summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Keith-Magee <russell@keith-magee.com>2024-03-28 07:59:33 (GMT)
committerGitHub <noreply@github.com>2024-03-28 07:59:33 (GMT)
commitf006338017cfbf846e8f7391b9ee5f69df8dc620 (patch)
tree6db12f901d882f53401dc2d3fafbe101c2b8fdbc /configure.ac
parentb44898299a2ed97045c270f6474785da2ff07ced (diff)
downloadcpython-f006338017cfbf846e8f7391b9ee5f69df8dc620.zip
cpython-f006338017cfbf846e8f7391b9ee5f69df8dc620.tar.gz
cpython-f006338017cfbf846e8f7391b9ee5f69df8dc620.tar.bz2
gh-114099: Additions to standard library to support iOS (GH-117052)
Co-authored-by: Hugo van Kemenade <1324225+hugovk@users.noreply.github.com> Co-authored-by: Malcolm Smith <smith@chaquo.com> Co-authored-by: Ned Deily <nad@python.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 11 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index cdfafc2..fc62bfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -715,16 +715,16 @@ if test "$cross_compiling" = yes; then
_host_device=`echo $host | cut -d '-' -f4`
_host_device=${_host_device:=os}
- dnl IOS_DEPLOYMENT_TARGET is the minimum supported iOS version
- IOS_DEPLOYMENT_TARGET=${_host_os:3}
- IOS_DEPLOYMENT_TARGET=${IOS_DEPLOYMENT_TARGET:=12.0}
+ # IPHONEOS_DEPLOYMENT_TARGET is the minimum supported iOS version
+ IPHONEOS_DEPLOYMENT_TARGET=${_host_os:3}
+ IPHONEOS_DEPLOYMENT_TARGET=${IPHONEOS_DEPLOYMENT_TARGET:=12.0}
case "$host_cpu" in
aarch64)
- _host_ident=${IOS_DEPLOYMENT_TARGET}-arm64-iphone${_host_device}
+ _host_ident=${IPHONEOS_DEPLOYMENT_TARGET}-arm64-iphone${_host_device}
;;
*)
- _host_ident=${IOS_DEPLOYMENT_TARGET}-$host_cpu-iphone${_host_device}
+ _host_ident=${IPHONEOS_DEPLOYMENT_TARGET}-$host_cpu-iphone${_host_device}
;;
esac
;;
@@ -866,6 +866,9 @@ AC_SUBST([EXPORT_MACOSX_DEPLOYMENT_TARGET])
CONFIGURE_MACOSX_DEPLOYMENT_TARGET=
EXPORT_MACOSX_DEPLOYMENT_TARGET='#'
+# Record the value of IPHONEOS_DEPLOYMENT_TARGET enforced by the selected host triple.
+AC_SUBST([IPHONEOS_DEPLOYMENT_TARGET])
+
# checks for alternative programs
# compiler flags are generated in two sets, BASECFLAGS and OPT. OPT is just
@@ -901,9 +904,8 @@ AS_CASE([$host],
dnl Add the compiler flag for the iOS minimum supported OS version.
AS_CASE([$ac_sys_system],
[iOS], [
- AS_VAR_APPEND([CFLAGS], [" -mios-version-min=${IOS_DEPLOYMENT_TARGET}"])
- AS_VAR_APPEND([LDFLAGS], [" -mios-version-min=${IOS_DEPLOYMENT_TARGET}"])
- AC_SUBST([IOS_DEPLOYMENT_TARGET])
+ AS_VAR_APPEND([CFLAGS], [" -mios-version-min=${IPHONEOS_DEPLOYMENT_TARGET}"])
+ AS_VAR_APPEND([LDFLAGS], [" -mios-version-min=${IPHONEOS_DEPLOYMENT_TARGET}"])
],
)
@@ -6939,6 +6941,7 @@ AC_ARG_WITH([ensurepip],
AS_CASE([$ac_sys_system],
[Emscripten], [with_ensurepip=no],
[WASI], [with_ensurepip=no],
+ [iOS], [with_ensurepip=no],
[with_ensurepip=upgrade]
)
])