summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2013-08-21 11:26:05 (GMT)
committerChristian Heimes <christian@cheimes.de>2013-08-21 11:26:05 (GMT)
commitf77b4b20e931dd0247a176db856723fe1203d32e (patch)
tree2db44f24a8c5695c53df730205a043d11fb6c272 /configure.ac
parentb1973c252c2eec757eaa067afaf593c2cc5ea8db (diff)
downloadcpython-f77b4b20e931dd0247a176db856723fe1203d32e.zip
cpython-f77b4b20e931dd0247a176db856723fe1203d32e.tar.gz
cpython-f77b4b20e931dd0247a176db856723fe1203d32e.tar.bz2
Issue #18747: Re-seed OpenSSL's pseudo-random number generator after fork.
A pthread_atfork() child handler is used to seeded the PRNG with pid, time and some stack data.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 501c1da..b53dee2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2500,6 +2500,7 @@ if test "$posix_threads" = "yes"; then
[Define if pthread_sigmask() does not work on your system.])
;;
esac])
+ AC_CHECK_FUNCS(pthread_atfork)
fi