summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRalf Schmitt <ralf@systemexit.de>2011-05-31 22:10:03 (GMT)
committerRalf Schmitt <ralf@systemexit.de>2011-05-31 22:10:03 (GMT)
commit023f3a7cf6124498598ec82e03baa1219783deed (patch)
treea6719fbccf5f5b548072c36285f3e04248e22da3 /configure.in
parentbc93a116eb8f73bae881503feb17d966d61680ed (diff)
downloadcpython-023f3a7cf6124498598ec82e03baa1219783deed.zip
cpython-023f3a7cf6124498598ec82e03baa1219783deed.tar.gz
cpython-023f3a7cf6124498598ec82e03baa1219783deed.tar.bz2
disable ASDLGEN if hg won't work, or if python is not installed.
This change makes configure check for - the existence of a hg repository - the hg executable itself - the python executable Running $(srcdir)/Parser/asdl_c.py (i.e. ASDLGEN) will fail if any of the above prerequisites is missing, so we now disable it instead. closes #12225
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b5f155d..49932de 100644
--- a/configure.in
+++ b/configure.in
@@ -811,7 +811,13 @@ fi
AC_SUBST(HGVERSION)
AC_SUBST(HGTAG)
AC_SUBST(HGBRANCH)
+
+if test -e $srcdir/.hg/00changelog.i
+then
AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+else
+HAS_HG=no-repository
+fi
if test $HAS_HG = found
then
HGVERSION="hg id -i \$(srcdir)"
@@ -823,6 +829,15 @@ else
HGBRANCH=""
fi
+AC_SUBST(DISABLE_ASDLGEN)
+DISABLE_ASDLGEN=""
+AC_CHECK_PROG(HAS_PYTHON, python, found, not-found)
+if test $HAS_HG != found -o $HAS_PYTHON != found
+then
+ DISABLE_ASDLGEN="@echo hg: $HAS_HG, python: $HAS_PYTHON! cannot run \$(srcdir)/Parser/asdl_c.py #"
+fi
+
+
case $MACHDEP in
bsdos*|hp*|HP*)
# install -d does not work on BSDI or HP-UX