summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2009-12-03 03:01:27 (GMT)
committerBenjamin Peterson <benjamin@python.org>2009-12-03 03:01:27 (GMT)
commit05159c4a7b37403613772a0883bd927bb57e8060 (patch)
treebd3c0dd69a88c3605039545f90ee6246637cac24 /configure.in
parentcb134d7d88baf08b9edcc4bf653be95bb2718bd2 (diff)
downloadcpython-05159c4a7b37403613772a0883bd927bb57e8060.zip
cpython-05159c4a7b37403613772a0883bd927bb57e8060.tar.gz
cpython-05159c4a7b37403613772a0883bd927bb57e8060.tar.bz2
Merged revisions 76644 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r76644 | benjamin.peterson | 2009-12-02 20:52:39 -0600 (Wed, 02 Dec 2009) | 4 lines disable pymalloc tricks with the --with-valgrind option #2422 Patch from James Henstridge. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a7a596e..45601d5 100644
--- a/configure.in
+++ b/configure.in
@@ -2345,6 +2345,19 @@ then
fi
AC_MSG_RESULT($with_pymalloc)
+# Check for Valgrind support
+AC_MSG_CHECKING([for --with-valgrind])
+AC_ARG_WITH([valgrind],
+ AC_HELP_STRING([--with-valgrind], [Enable Valgrind support]),,
+ with_valgrind=no)
+AC_MSG_RESULT([$with_valgrind])
+if test "$with_valgrind" != no; then
+ AC_CHECK_HEADER([valgrind/valgrind.h],
+ [AC_DEFINE([WITH_VALGRIND], 1, [Define if you want pymalloc to be disabled when running under valgrind])],
+ [AC_MSG_ERROR([Valgrind support requested but headers not available])]
+ )
+fi
+
# Check for --with-wctype-functions
AC_MSG_CHECKING(for --with-wctype-functions)
AC_ARG_WITH(wctype-functions,