summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:40:06 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:40:06 (GMT)
commit175a88458e1d8b79c07e90df95534c66b10339ec (patch)
treecca4d57cf140e7e71da9816f557f8c6a6a0525da /configure.in
parentc8c89c4e6292df2ed1c269f51e7dc51b380f9e5b (diff)
downloadcpython-175a88458e1d8b79c07e90df95534c66b10339ec.zip
cpython-175a88458e1d8b79c07e90df95534c66b10339ec.tar.gz
cpython-175a88458e1d8b79c07e90df95534c66b10339ec.tar.bz2
Merged revisions 78156 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ................ r78156 | ronald.oussoren | 2010-02-11 14:38:58 +0100 (Thu, 11 Feb 2010) | 9 lines Merged revisions 78154 via svnmerge from svn+ssh://pythondev@svn.python.org/python/trunk ........ r78154 | ronald.oussoren | 2010-02-11 14:26:54 +0100 (Thu, 11 Feb 2010) | 2 lines Finish fix for issue 7715, after explicit search for calls to `arch` ........ ................
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 85c065f..0022d02 100644
--- a/configure.in
+++ b/configure.in
@@ -958,7 +958,7 @@ yes)
cur_target='10.5'
fi
else
- if test `arch` = "i386"; then
+ if test `/usr/bin/arch` = "i386"; then
# On Intel macs default to a deployment
# target of 10.4, that's the first OSX
# release with Intel support.
@@ -1526,7 +1526,7 @@ case $ac_sys_system/$ac_sys_release in
if test "${enable_universalsdk}"; then
:
else
- LIBTOOL_CRUFT="${LIBTOOL_CRUFT} -arch_only `arch`"
+ LIBTOOL_CRUFT="${LIBTOOL_CRUFT} -arch_only `/usr/bin/arch`"
fi
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
@@ -1553,7 +1553,7 @@ case $ac_sys_system/$ac_sys_release in
ac_osx_32bit=yes)
if test "${ac_osx_32bit}" = "yes"; then
- case `arch` in
+ case `/usr/bin/arch` in
i386)
MACOSX_DEFAULT_ARCH="i386"
;;
@@ -1565,7 +1565,7 @@ case $ac_sys_system/$ac_sys_release in
;;
esac
else
- case `arch` in
+ case `/usr/bin/arch` in
i386)
MACOSX_DEFAULT_ARCH="x86_64"
;;