summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeremy Hylton <jeremy@alum.mit.edu>2000-10-16 16:59:12 (GMT)
committerJeremy Hylton <jeremy@alum.mit.edu>2000-10-16 16:59:12 (GMT)
commit1a2ca86a4f2356bb4d545f60f2da888cd13123a4 (patch)
tree898de7aebfcd8661210a9fc2bb5482957fc406d6 /configure.in
parent75f8101c429e132472bba92f3972b7eac68f35f8 (diff)
downloadcpython-1a2ca86a4f2356bb4d545f60f2da888cd13123a4.zip
cpython-1a2ca86a4f2356bb4d545f60f2da888cd13123a4.tar.gz
cpython-1a2ca86a4f2356bb4d545f60f2da888cd13123a4.tar.bz2
Patch #101936: Auto-detect DEC threads (which need "-threads" argument)
by Thomas Wouters
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3595d70..7445e6d 100644
--- a/configure.in
+++ b/configure.in
@@ -805,6 +805,15 @@ else
LIBS="$LIBS -lthread"
LIBOBJS="$LIBOBJS thread.o"
USE_THREAD_MODULE=""])
+
+ if test "$USE_THREAD_MODULE" != "#"
+ then
+ # If the above checks didn't disable threads, (at least) OSF1
+ # needs this '-threads' argument during linking.
+ case $ac_sys_system in
+ OSF1) LDLAST=-threads;;
+ esac
+ fi
fi
# Check for GC support