summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeremy Hylton <jeremy@alum.mit.edu>2000-06-30 04:57:55 (GMT)
committerJeremy Hylton <jeremy@alum.mit.edu>2000-06-30 04:57:55 (GMT)
commit2a2c218525f148011d3308ffbecfec1e0c2859a7 (patch)
treedeed5911edb1921e7509ce8232d2b2fad6484dd0 /configure.in
parent57a2f7f8ef59c972624215bf20fa97b55152f97e (diff)
downloadcpython-2a2c218525f148011d3308ffbecfec1e0c2859a7.zip
cpython-2a2c218525f148011d3308ffbecfec1e0c2859a7.tar.gz
cpython-2a2c218525f148011d3308ffbecfec1e0c2859a7.tar.bz2
penultimate phase of Neil Schemenauer's GC patches
update configure files (turn --with-cycle-gc on for beta release?)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c7174f1..152d1f0 100644
--- a/configure.in
+++ b/configure.in
@@ -1116,6 +1116,17 @@ else AC_MSG_RESULT(no)
fi],
[AC_MSG_RESULT(no)])
+# Check for GC support
+AC_SUBST(USE_GC_MODULE)
+USE_GC_MODULE="#"
+AC_MSG_CHECKING(for --with-cycle-gc)
+AC_ARG_WITH(cycle-gc, [--with-cycle-gc enable garbage collection], [
+AC_MSG_RESULT($withval)
+AC_DEFINE(WITH_CYCLE_GC)
+USE_GC_MODULE=
+],
+AC_MSG_RESULT(no))
+
# THIS MUST BE LAST, IT CAN BREAK OTHER TESTS!
# Add sys/socket.h to confdefs.h
cat >> confdefs.h <<\EOF