summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-31 21:22:50 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-31 21:22:50 (GMT)
commit2df5d28155e922f7972a02d8411c1b47f3fa812c (patch)
tree42b9c5aaa7deab98cc1bfdced9f6466d28c10577 /configure.in
parent89d7d416026101a382b37ab8e1595658976fa180 (diff)
downloadcpython-2df5d28155e922f7972a02d8411c1b47f3fa812c.zip
cpython-2df5d28155e922f7972a02d8411c1b47f3fa812c.tar.gz
cpython-2df5d28155e922f7972a02d8411c1b47f3fa812c.tar.bz2
Merged revisions 77193 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r77193 | mark.dickinson | 2009-12-31 21:11:48 +0000 (Thu, 31 Dec 2009) | 1 line More configure fixes: avoid sh 'integer argument expected' error when 'long long' type doesn't exist. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ef756f1..0abb2ba 100644
--- a/configure.in
+++ b/configure.in
@@ -1396,8 +1396,9 @@ AC_CHECK_SIZEOF(off_t, [], [
])
AC_MSG_CHECKING(whether to enable large file support)
-if test "$have_long_long" = yes -a \
- "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
+if test "$have_long_long" = yes
+then
+if test "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
"$ac_cv_sizeof_long_long" -ge "$ac_cv_sizeof_off_t"; then
AC_DEFINE(HAVE_LARGEFILE_SUPPORT, 1,
[Defined to enable large file support when an off_t is bigger than a long
@@ -1408,6 +1409,9 @@ if test "$have_long_long" = yes -a \
else
AC_MSG_RESULT(no)
fi
+else
+ AC_MSG_RESULT(no)
+fi
AC_CHECK_SIZEOF(time_t, [], [
#ifdef HAVE_SYS_TYPES_H
@@ -2837,7 +2841,7 @@ int main()
ac_cv_buggy_getaddrinfo=yes))
fi
-if test $have_getaddrinfo = no -o $ac_cv_buggy_getaddrinfo = yes
+if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
then
if test $ipv6 = yes
then