summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJason Tishler <jason@tishler.net>2003-09-04 11:04:06 (GMT)
committerJason Tishler <jason@tishler.net>2003-09-04 11:04:06 (GMT)
commit3076559ea5d36d9795edc32e2fae7949b875d7ef (patch)
treee49bc5e2702644ded35d213f91a6465ada389523 /configure.in
parent8ad1dd7df11454abf51354e4f6ddef69167088f9 (diff)
downloadcpython-3076559ea5d36d9795edc32e2fae7949b875d7ef.zip
cpython-3076559ea5d36d9795edc32e2fae7949b875d7ef.tar.gz
cpython-3076559ea5d36d9795edc32e2fae7949b875d7ef.tar.bz2
This patch enables the building of Cygwin Python with a static core
which still supports shared extensions. It takes advantage the latest Cygwin binutils (i.e., 20030901-1) which can export symbols from executables: http://cygwin.com/ml/cygwin-announce/2003-09/msg00002.html Additionally, it finally lays to rest the following mailing list subthread: http://mail.python.org/pipermail/python-list/2002-May/102500.html I tested the patch under Red Hat Linux 8.0 too
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 00483ed..44da831 100644
--- a/configure.in
+++ b/configure.in
@@ -539,6 +539,13 @@ if test $enable_shared = "yes"; then
BASECFLAGS="$BASECFLAGS -pic"
;;
esac
+else # shared is disabled
+ case $ac_sys_system in
+ CYGWIN*)
+ BLDLIBRARY='$(LIBRARY)'
+ LDLIBRARY='libpython$(VERSION).dll.a'
+ ;;
+ esac
fi
AC_MSG_RESULT($LDLIBRARY)
@@ -1371,6 +1378,11 @@ then
LINKFORSHARED="-Xlinker --export-dynamic"
fi;;
esac;;
+ CYGWIN*)
+ if test $enable_shared = "no"
+ then
+ LINKFORSHARED='-Wl,--out-implib=$(LDLIBRARY)'
+ fi;;
esac
fi
AC_MSG_RESULT($LINKFORSHARED)