summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2001-07-10 16:45:32 (GMT)
committerGuido van Rossum <guido@python.org>2001-07-10 16:45:32 (GMT)
commit353ae5896499d0ec297cff00e3686f4cd88668c3 (patch)
tree2d4bc47e3fc79a3c702b7ef6ff16101620341b4a /configure.in
parentd854831ddd2adbec80f38ffb26a0f355b9c8772e (diff)
downloadcpython-353ae5896499d0ec297cff00e3686f4cd88668c3.zip
cpython-353ae5896499d0ec297cff00e3686f4cd88668c3.tar.gz
cpython-353ae5896499d0ec297cff00e3686f4cd88668c3.tar.bz2
SF Patch #432457 by Jason Tishler: support for readline 4.2.
This patch allows the readline module to build cleanly with GNU readline 4.2 without breaking the build for earlier GNU readline versions. The configure script checks for the presence of rl_completion_matches in libreadline.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5fa50cf..65ee7b4 100644
--- a/configure.in
+++ b/configure.in
@@ -1661,6 +1661,10 @@ then
AC_DEFINE(HAVE_GETC_UNLOCKED)
fi
+# check for readline 4.2
+AC_CHECK_LIB(readline, rl_completion_matches,
+ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES), , -ltermcap)
+
# THIS MUST BE LAST, IT CAN BREAK OTHER TESTS!
# Add sys/socket.h to confdefs.h
cat >> confdefs.h <<\EOF