summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2007-09-02 09:46:07 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2007-09-02 09:46:07 (GMT)
commit38f1b98cc3b951ac48f606df8b633793dbf5cf5b (patch)
tree5d622e524ad82f5d00e58c62c6a6645e2255fbdc /configure.in
parentb4c629566cf9eab713be13214261b3a77e6d9231 (diff)
downloadcpython-38f1b98cc3b951ac48f606df8b633793dbf5cf5b.zip
cpython-38f1b98cc3b951ac48f606df8b633793dbf5cf5b.tar.gz
cpython-38f1b98cc3b951ac48f606df8b633793dbf5cf5b.tar.bz2
Macosx: this patch ensures that the value of MACOSX_DEPLOYMENT_TARGET used
by the Makefile is also used at configure-time.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ef9601d..dd8e117 100644
--- a/configure.in
+++ b/configure.in
@@ -1509,6 +1509,14 @@ then
cur_target=10.3
fi
CONFIGURE_MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET-${cur_target}}
+
+ # Make sure that MACOSX_DEPLOYMENT_TARGET is set in the
+ # environment with a value that is the same as what we'll use
+ # in the Makefile to ensure that we'll get the same compiler
+ # environment during configure and build time.
+ MACOSX_DEPLOYMENT_TARGET="$CONFIGURE_MACOSX_DEPLOYMENT_TARGET"
+ export MACOSX_DEPLOYMENT_TARGET
+
EXPORT_MACOSX_DEPLOYMENT_TARGET=''
if test ${MACOSX_DEPLOYMENT_TARGET-${cur_target}} '>' 10.2
then