summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2000-10-07 16:21:27 (GMT)
committerGuido van Rossum <guido@python.org>2000-10-07 16:21:27 (GMT)
commit4095101c78c6313286306cb55b8aa5f840ce9197 (patch)
tree1f4fe23242fe9e79e6ccdb01e9036f38da38c6d8 /configure.in
parent77878413bae310a1ebb172c83a9484ca55d48b17 (diff)
downloadcpython-4095101c78c6313286306cb55b8aa5f840ce9197.zip
cpython-4095101c78c6313286306cb55b8aa5f840ce9197.tar.gz
cpython-4095101c78c6313286306cb55b8aa5f840ce9197.tar.bz2
Put arguments to test -z in double quotes. Fixes Bug #116325.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index eefea04..8517d56 100644
--- a/configure.in
+++ b/configure.in
@@ -750,10 +750,10 @@ if test "$with_threads" = "no"
then
USE_THREAD_MODULE="#"
else
- if test ! -z $with_threads -a -d $with_threads
+ if test ! -z "$with_threads" -a -d "$with_threads"
then LDFLAGS="$LDFLAGS -L$with_threads"
fi
- if test ! -z $withval -a -d $withval
+ if test ! -z "$withval" -a -d "$withval"
then LDFLAGS="$LDFLAGS -L$withval"
fi
AC_DEFINE(_REENTRANT)
@@ -889,7 +889,7 @@ AC_MSG_RESULT($withval)
AC_DEFINE(WITH_SGI_DL)
DYNLOADFILE="dynload_dl.o"
dldir=$withval
-if test ! -z $dldir -a -d $dldir
+if test ! -z "$dldir" -a -d "$dldir"
then LDFLAGS="$LDFLAGS -L$dldir"
else AC_ERROR(proper usage is --with-sgi-dl=DIRECTORY)
fi