summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 16:37:33 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 16:37:33 (GMT)
commit5511442f78af13fb3ca5723341f13d831e411291 (patch)
tree962d57737bce2a63177ac9c4d21d2b25fae41551 /configure.in
parent2f0ff2acd353b188c7e1164e0d486db7478109e0 (diff)
downloadcpython-5511442f78af13fb3ca5723341f13d831e411291.zip
cpython-5511442f78af13fb3ca5723341f13d831e411291.tar.gz
cpython-5511442f78af13fb3ca5723341f13d831e411291.tar.bz2
Merged revisions 76403 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r76403 | ronald.oussoren | 2009-11-19 17:25:21 +0100 (Thu, 19 Nov 2009) | 14 lines Fix for issue #7085 On MacOSX 10.6 the CoreFoundation framework must be initialized on the main thread, the constructor function in that framework will cause an SIGABRT when it is called on any other thread. Because a number of extension link (indirectly) to CoreFoundation and the Python core itself didn't the interpreter crashed when importing some extensions, such as _locale, on a secondary thread. This fix ensures that Python is linked to CoreFoundation on OSX, which results in the CoreFoundation constructor being called when Python is loaded. This does not require code changes. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa43374..42af0f8 100644
--- a/configure.in
+++ b/configure.in
@@ -3841,6 +3841,13 @@ do
THREADHEADERS="$THREADHEADERS \$(srcdir)/$h"
done
+if test $ac_sys_system = Darwin
+then
+ LIBS="$LIBS -framework CoreFoundation"
+fi
+
+
+
AC_SUBST(SRCDIRS)
SRCDIRS="Parser Grammar Objects Python Modules Mac"
AC_MSG_CHECKING(for build directories)