summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTarek Ziadé <ziade.tarek@gmail.com>2009-05-07 21:24:43 (GMT)
committerTarek Ziadé <ziade.tarek@gmail.com>2009-05-07 21:24:43 (GMT)
commit5662d3e676088b43d3138d48819ce7410292198d (patch)
treef190db92a6ccfa4961db334be54032135c2316d7 /configure.in
parent72b06c6be08e9b1b27ee9c9963d5acec56b11d9c (diff)
downloadcpython-5662d3e676088b43d3138d48819ce7410292198d.zip
cpython-5662d3e676088b43d3138d48819ce7410292198d.tar.gz
cpython-5662d3e676088b43d3138d48819ce7410292198d.tar.bz2
Merged revisions 72445 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r72445 | tarek.ziade | 2009-05-07 23:20:34 +0200 (Thu, 07 May 2009) | 1 line Fixed #5941: added ARFLAGS for the archiver command. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ba43b21..2591d8d 100644
--- a/configure.in
+++ b/configure.in
@@ -726,6 +726,13 @@ AC_PROG_RANLIB
AC_SUBST(AR)
AC_CHECK_PROGS(AR, ar aal, ar)
+# tweak ARFLAGS only if the user didn't set it on the command line
+AC_SUBST(ARFLAGS)
+if test -z "$ARFLAGS"
+then
+ ARFLAGS="rc"
+fi
+
AC_SUBST(SVNVERSION)
AC_CHECK_PROG(SVNVERSION, svnversion, found, not-found)
if test $SVNVERSION = found