summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGreg Ward <gward@python.net>2000-05-26 12:22:54 (GMT)
committerGreg Ward <gward@python.net>2000-05-26 12:22:54 (GMT)
commit57c9a663cb4fcb42beb96ba65adde6034eb66279 (patch)
treec62bce6601d359b1aff0c3093b5be8750a12e81f /configure.in
parent99d707af476c127cbbb42a914ee0116a8f3cc319 (diff)
downloadcpython-57c9a663cb4fcb42beb96ba65adde6034eb66279.zip
cpython-57c9a663cb4fcb42beb96ba65adde6034eb66279.tar.gz
cpython-57c9a663cb4fcb42beb96ba65adde6034eb66279.tar.bz2
When building on Solaris and the compiler is GCC, use '$(CC) -G' to
create shared extensions rather than 'ld -G'. This ensures that shared extensions link against libgcc.a, in case there are any functions in the GCC runtime not already in the Python core.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c088313..bd1b674 100644
--- a/configure.in
+++ b/configure.in
@@ -493,7 +493,11 @@ then
IRIX/5*) LDSHARED="ld -shared";;
IRIX*/6*) LDSHARED="ld ${SGI_ABI} -shared -all";;
SunOS/4*) LDSHARED="ld";;
- SunOS/5*) LDSHARED="ld -G";;
+ SunOS/5*)
+ if test "$GCC" = "yes"
+ then LDSHARED='$(CC) -G'
+ else LDSHARED="ld -G";
+ fi ;;
hp*|HP*) LDSHARED="ld -b";;
OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;
DYNIX/ptx*) LDSHARED="ld -G";;