summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1994-11-10 23:06:54 (GMT)
committerGuido van Rossum <guido@python.org>1994-11-10 23:06:54 (GMT)
commit5dee5e7dc0ba0a15a0b41fcaaf6b0577cabd4ea3 (patch)
treea9caf24417a1f6d5a8f7a84e8d64b750a328347b /configure.in
parent635649f90f69b7183a68df1d51e7875639bcdb8c (diff)
downloadcpython-5dee5e7dc0ba0a15a0b41fcaaf6b0577cabd4ea3.zip
cpython-5dee5e7dc0ba0a15a0b41fcaaf6b0577cabd4ea3.tar.gz
cpython-5dee5e7dc0ba0a15a0b41fcaaf6b0577cabd4ea3.tar.bz2
bugfix release
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 43155b2..c818930 100644
--- a/configure.in
+++ b/configure.in
@@ -123,7 +123,8 @@ then
fi
# checks for libraries
-AC_HAVE_LIBRARY(dl)
+AC_HAVE_LIBRARY(dl) # Dynamic linking for SunOS/Solaris (and SYSV?)
+AC_HAVE_LIBRARY(dld) # Dynamic linking for HP-UX
AC_CHECKING(for --with-svr4)
AC_WITH(svr4, [
@@ -239,9 +240,15 @@ AC_CHECKING(for bad static forward)
AC_TEST_PROGRAM([
struct s { int a; int b; };
static struct s foo;
-int foobar() { return !foo.a; }
+int foobar() {
+ static int random;
+ random = (int) &foo;
+ return random;
+}
static struct s foo = { 1, 2 };
-main() { exit(foobar()); }
+main() {
+ exit(!((int)&foo == foobar()));
+}
], , AC_DEFINE(BAD_STATIC_FORWARD))
# checks for system services