summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-02-25 11:04:50 (GMT)
committerGeorg Brandl <georg@python.org>2011-02-25 11:04:50 (GMT)
commit71f4fbb0b74b45df75c81aad80d204df0a315ae4 (patch)
tree9cbdbd2b4789cc82bde573b3c0cb29d261ef925a /configure.in
parent280460271df4ebc3d3129754b4f327a118b0c3b0 (diff)
downloadcpython-71f4fbb0b74b45df75c81aad80d204df0a315ae4.zip
cpython-71f4fbb0b74b45df75c81aad80d204df0a315ae4.tar.gz
cpython-71f4fbb0b74b45df75c81aad80d204df0a315ae4.tar.bz2
Merged revisions 88426 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r88426 | georg.brandl | 2011-02-15 16:44:51 +0100 (Di, 15 Feb 2011) | 1 line #941346: Fix broken shared library build on AIX. Patch by Sebastien Sable, review by Antoine Pitrou. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 9e6eeeb..ed2f613 100644
--- a/configure.in
+++ b/configure.in
@@ -5,14 +5,7 @@ dnl ***********************************************
# Set VERSION so we only need to edit in one place (i.e., here)
m4_define(PYTHON_VERSION, 2.7)
-dnl Some m4 magic to ensure that the configure script is generated
-dnl by the correct autoconf version.
-m4_define([version_required],
-[m4_if(m4_version_compare(m4_defn([m4_PACKAGE_VERSION]), [$1]), 0,
- [],
- [m4_fatal([Autoconf version $1 is required for Python], 63)])
-])
-version_required(2.65)
+AC_PREREQ(2.65)
AC_REVISION($Revision$)
AC_INIT(python, PYTHON_VERSION, http://bugs.python.org/)
@@ -1764,7 +1757,7 @@ if test -z "$LDSHARED"
then
case $ac_sys_system/$ac_sys_release in
AIX*)
- BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:Modules/python.exp -L\$(srcdir)"
+ BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:\$(srcdir)/Modules/python.exp"
LDSHARED="\$(BINLIBDEST)/config/ld_so_aix \$(CC) -bI:\$(BINLIBDEST)/config/python.exp"
;;
BeOS*)