summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-03-17 15:44:10 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-03-17 15:44:10 (GMT)
commit7b59b42a3803b965e9b5f3ad2fdd3999c95480e6 (patch)
tree26de1343b0b166c92f3d206e540b4c254e9d5561 /configure.in
parentdcf6d2c97dbe7b7126cc4dfeb39d424a4397cdc6 (diff)
downloadcpython-7b59b42a3803b965e9b5f3ad2fdd3999c95480e6.zip
cpython-7b59b42a3803b965e9b5f3ad2fdd3999c95480e6.tar.gz
cpython-7b59b42a3803b965e9b5f3ad2fdd3999c95480e6.tar.bz2
Added a define EXTRAMACHDEPPATH which can be used to add sys.path items
for specific platforms. Use this to add plat-mac and plat-mac/lib-scriptpackages on MacOSX. Also tested for not having adverse effects on Linux, and I think this code isn't used on Windows anyway. Fixes #661521.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bcde551..229caef 100644
--- a/configure.in
+++ b/configure.in
@@ -157,12 +157,19 @@ AC_MSG_RESULT($MACHDEP)
# And add extra plat-mac for darwin
AC_SUBST(EXTRAPLATDIR)
+AC_SUBST(EXTRAMACHDEPPATH)
AC_MSG_CHECKING(EXTRAPLATDIR)
if test -z "$EXTRAPLATDIR"
then
case $MACHDEP in
- darwin) EXTRAPLATDIR="\$(PLATMACDIRS)";;
- *) EXTRAPLATDIR="";;
+ darwin)
+ EXTRAPLATDIR="\$(PLATMACDIRS)"
+ EXTRAMACHDEPPATH="\$(PLATMACPATH)"
+ ;;
+ *)
+ EXTRAPLATDIR=""
+ EXTRAMACHDEPPATH=""
+ ;;
esac
fi
AC_MSG_RESULT($EXTRAPLATDIR)