summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2000-10-05 18:45:53 (GMT)
committerBarry Warsaw <barry@python.org>2000-10-05 18:45:53 (GMT)
commit7d1219d9bdb9598c95636daac741896f2167b09f (patch)
tree899694e1f976e0196527ec9413a53f66538ea85c /configure.in
parent3dc0a514e6d6dd1e1b6ed3aa82fcdaa909bfea7f (diff)
downloadcpython-7d1219d9bdb9598c95636daac741896f2167b09f.zip
cpython-7d1219d9bdb9598c95636daac741896f2167b09f.tar.gz
cpython-7d1219d9bdb9598c95636daac741896f2167b09f.tar.bz2
Change all occurances of
test -d "$directory" to test ! -z "directory" -a -d "directory" Apparently, on SunOS 4.1.4_JL (and other?) OSes, -d on an empty string always returns true. This closes SF bug #115392.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e2adc75..eefea04 100644
--- a/configure.in
+++ b/configure.in
@@ -750,10 +750,10 @@ if test "$with_threads" = "no"
then
USE_THREAD_MODULE="#"
else
- if test -d "$with_threads"
+ if test ! -z $with_threads -a -d $with_threads
then LDFLAGS="$LDFLAGS -L$with_threads"
fi
- if test -d "$withval"
+ if test ! -z $withval -a -d $withval
then LDFLAGS="$LDFLAGS -L$withval"
fi
AC_DEFINE(_REENTRANT)
@@ -889,7 +889,7 @@ AC_MSG_RESULT($withval)
AC_DEFINE(WITH_SGI_DL)
DYNLOADFILE="dynload_dl.o"
dldir=$withval
-if test -d "$dldir"
+if test ! -z $dldir -a -d $dldir
then LDFLAGS="$LDFLAGS -L$dldir"
else AC_ERROR(proper usage is --with-sgi-dl=DIRECTORY)
fi
@@ -903,7 +903,7 @@ AC_DEFINE(WITH_DL_DLD)
DYNLOADFILE="dynload_dl.o"
dldir=`echo "$withval" | sed 's/,.*//'`
dlddir=`echo "$withval" | sed 's/.*,//'`
-if test -d "$dldir" -a -d "$dlddir"
+if test ! -z "$dldir" -a -d "$dldir" -a ! -z "$dlddir" -a -d "$dlddir"
then LDFLAGS="$LDFLAGS -L$dldir -L$dlddir"
else AC_ERROR(proper usage is --with-dl-dld=DL_DIRECTORY,DLD_DIRECTORY)
fi