summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1999-04-10 16:01:48 (GMT)
committerGuido van Rossum <guido@python.org>1999-04-10 16:01:48 (GMT)
commit8bc1dfd2fbf3f830c5277470274cd35369e2ff5f (patch)
tree3f3162b664610ff87148273871b6f0ca9484924a /configure.in
parentff1ccbfc2172c564c6ca93113e1a1cf9a271f6ef (diff)
downloadcpython-8bc1dfd2fbf3f830c5277470274cd35369e2ff5f.zip
cpython-8bc1dfd2fbf3f830c5277470274cd35369e2ff5f.tar.gz
cpython-8bc1dfd2fbf3f830c5277470274cd35369e2ff5f.tar.bz2
Quote a bunch of shell variables used in test, related to long-long.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 2fc3d8e..993a8a6 100644
--- a/configure.in
+++ b/configure.in
@@ -354,7 +354,7 @@ AC_MSG_CHECKING(for long long support)
have_long_long=no
AC_TRY_COMPILE([], [long long x; x = (long long)0;], AC_DEFINE(HAVE_LONG_LONG) have_long_long=yes)
AC_MSG_RESULT($have_long_long)
-if test $have_long_long = yes ; then
+if test "$have_long_long" = yes ; then
AC_CHECK_SIZEOF(long long)
fi
@@ -375,9 +375,9 @@ AC_MSG_RESULT($ac_cv_sizeof_off_t)
AC_DEFINE_UNQUOTED(SIZEOF_OFF_T, $ac_cv_sizeof_off_t)
AC_MSG_CHECKING(whether to enable large file support)
-if test $have_long_long = yes -a \
- $ac_cv_sizeof_off_t -gt $ac_cv_sizeof_long -a \
- $ac_cv_sizeof_long_long -ge $ac_cv_sizeof_off_t; then
+if test "$have_long_long" = yes -a \
+ "$ac_cv_sizeof_off_t" -gt "$ac_cv_sizeof_long" -a \
+ "$ac_cv_sizeof_long_long" -ge "$ac_cv_sizeof_off_t"; then
AC_DEFINE(HAVE_LARGEFILE_SUPPORT)
AC_MSG_RESULT(yes)
else