summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2010-05-11 09:23:07 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2010-05-11 09:23:07 (GMT)
commit8c2b6f1f5ab64b82c104095e6ad9157d38bc8079 (patch)
tree153ac1903efd0247e48bef4eb9a0a63fd95c452a /configure.in
parent899e9a0e7a0e8cd93bc15e3b4a74c479b0de74cd (diff)
downloadcpython-8c2b6f1f5ab64b82c104095e6ad9157d38bc8079.zip
cpython-8c2b6f1f5ab64b82c104095e6ad9157d38bc8079.tar.gz
cpython-8c2b6f1f5ab64b82c104095e6ad9157d38bc8079.tar.bz2
Recorded merge of revisions 81077 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r81077 | mark.dickinson | 2010-05-11 09:55:06 +0100 (Tue, 11 May 2010) | 3 lines Issue #8510: Remove nested 'main' functions (causing failure) in 3 configure tests; remove some unnecessary '#include "confdefs.h"' lines. Thanks Roumen Petrov. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 5 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 5993e05..c9ff87b 100644
--- a/configure.in
+++ b/configure.in
@@ -916,14 +916,14 @@ yes)
AC_CACHE_VAL(ac_cv_no_strict_aliasing,
AC_COMPILE_IFELSE(
[
- AC_LANG_PROGRAM([[]], [[int main() { return 0; }]])
+ AC_LANG_PROGRAM([[]], [[]])
],[
CC="$ac_save_cc -fstrict-aliasing"
CFLAGS="$CFLAGS -Werror -Wstrict-aliasing"
AC_COMPILE_IFELSE(
[
- AC_LANG_PROGRAM([[]],
- [[void f(int **x) {} int main() { double *x; f((int **) &x); return 0; }]])
+ AC_LANG_PROGRAM([[void f(int **x) {}]],
+ [[double *x; f((int **) &x);]])
],[
ac_cv_no_strict_aliasing=no
],[
@@ -1099,7 +1099,7 @@ AC_CACHE_VAL(ac_cv_opt_olimit_ok,
[ac_save_cc="$CC"
CC="$CC -OPT:Olimit=0"
AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[]], [[int main() { return 0; }]])],
+ [AC_LANG_PROGRAM([[]], [[]])],
[ac_cv_opt_olimit_ok=yes],
[ac_cv_opt_olimit_ok=no]
)
@@ -1122,7 +1122,7 @@ else
[ac_save_cc="$CC"
CC="$CC -Olimit 1500"
AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM([[]], [[int main() { return 0; }]])],
+ [AC_LANG_PROGRAM([[]], [[]])],
[ac_cv_olimit_ok=yes],
[ac_cv_olimit_ok=no]
)
@@ -2663,7 +2663,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_CHECKING(for ctermid_r)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <stdio.h>
]], [[void* p = ctermid_r]])],
[AC_DEFINE(HAVE_CTERMID_R, 1, Define if you have the 'ctermid_r' function.)
@@ -2673,7 +2672,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_CHECKING(for flock)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <sys/file.h>
]], [[void* p = flock]])],
[AC_DEFINE(HAVE_FLOCK, 1, Define if you have the 'flock' function.)
@@ -2683,7 +2681,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_CHECKING(for getpagesize)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <unistd.h>
]], [[void* p = getpagesize]])],
[AC_DEFINE(HAVE_GETPAGESIZE, 1, Define if you have the 'getpagesize' function.)
@@ -2774,7 +2771,6 @@ esac
AC_MSG_CHECKING(for hstrerror)
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <netdb.h>
]], [[void* p = hstrerror; hstrerror(0)]])],
[AC_DEFINE(HAVE_HSTRERROR, 1, Define if you have the 'hstrerror' function.)
@@ -2784,7 +2780,6 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_CHECKING(for inet_aton)
AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
@@ -2797,7 +2792,6 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_CHECKING(for inet_pton)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
@@ -2811,7 +2805,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
# On some systems, setgroups is in unistd.h, on others, in grp.h
AC_MSG_CHECKING(for setgroups)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include "confdefs.h"
#include <unistd.h>
#ifdef HAVE_GRP_H
#include <grp.h>