summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2000-06-30 16:39:35 (GMT)
committerBarry Warsaw <barry@python.org>2000-06-30 16:39:35 (GMT)
commita0f3c5c8d533acc7e86a85eaf95d6d9175a178f9 (patch)
tree2c9e030a387d18518cbc88e787f10798045b5841 /configure.in
parentab1c7918f683e540ae5651c1b585ecda16ae352d (diff)
downloadcpython-a0f3c5c8d533acc7e86a85eaf95d6d9175a178f9.zip
cpython-a0f3c5c8d533acc7e86a85eaf95d6d9175a178f9.tar.gz
cpython-a0f3c5c8d533acc7e86a85eaf95d6d9175a178f9.tar.bz2
Document --with-thread as deprecated. This gets rid of the annoying
newline in configure --help.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 876f71d..cbac1bf 100644
--- a/configure.in
+++ b/configure.in
@@ -661,7 +661,9 @@ AC_ARG_WITH(threads,
[ --with(out)-threads[=DIRECTORY] disable/enable thread support])
# --with-thread is deprecated, but check for it anyway
-AC_ARG_WITH(thread,,[with_threads=$with_thread])
+AC_ARG_WITH(thread,
+[ --with(out)-thread[=DIRECTORY] deprecated; use --with(out)-threads],[
+with_threads=$with_thread])
if test -z "$with_threads"
then with_threads="yes"