summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-02-27 04:45:05 (GMT)
committerNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-02-27 04:45:05 (GMT)
commita35c688055c72e9442f6a82c3ec0e09654077975 (patch)
tree081386e63e64467a01558567750b371baa527f8e /configure.in
parent29906eef3a56c43a4cd68a8706c75844b2384e59 (diff)
downloadcpython-a35c688055c72e9442f6a82c3ec0e09654077975.zip
cpython-a35c688055c72e9442f6a82c3ec0e09654077975.tar.gz
cpython-a35c688055c72e9442f6a82c3ec0e09654077975.tar.bz2
Add Vladimir Marangozov's object allocator. It is disabled by default. This
closes SF patch #401229.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ce4f1b0..16a578a 100644
--- a/configure.in
+++ b/configure.in
@@ -856,6 +856,16 @@ else
fi
AC_MSG_RESULT($with_cycle_gc)
+# Check for Python-specific malloc support
+AC_MSG_CHECKING(for --with-pymalloc)
+AC_ARG_WITH(pymalloc,
+[ --with(out)-pymalloc disable/enable specialized mallocs], [
+if test "$withval" != no
+then AC_DEFINE(WITH_PYMALLOC) AC_MSG_RESULT(yes)
+else AC_MSG_RESULT(no)
+fi],
+[AC_MSG_RESULT(no)])
+
# Check for --with-wctype-functions
AC_MSG_CHECKING(for --with-wctype-functions)
AC_ARG_WITH(wctype-functions,