summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2000-08-30 22:29:48 (GMT)
committerSkip Montanaro <skip@pobox.com>2000-08-30 22:29:48 (GMT)
commitcb853261bdfa32382aaa3f8f8ce7923059bdca3b (patch)
tree35541f586efd2e520d0f09ce0b272d2b505d57a7 /configure.in
parente68140dd3ced672b1f9e2c6e2c9ce11255d8b495 (diff)
downloadcpython-cb853261bdfa32382aaa3f8f8ce7923059bdca3b.zip
cpython-cb853261bdfa32382aaa3f8f8ce7923059bdca3b.tar.gz
cpython-cb853261bdfa32382aaa3f8f8ce7923059bdca3b.tar.bz2
adds support for --with-pydebug configure option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 73c8b7a30..3af6c3f 100644
--- a/configure.in
+++ b/configure.in
@@ -658,6 +658,16 @@ AC_MSG_RESULT($LINKFORSHARED)
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
+# Check for --with-pydebug
+AC_MSG_CHECKING(for --with-pydebug)
+AC_ARG_WITH(pydebug,
+[ --with-pydebug build with Py_DEBUG defined], [
+if test "$withval" != no
+then AC_DEFINE(Py_DEBUG) AC_MSG_RESULT(yes)
+else AC_MSG_RESULT(no)
+fi],
+[AC_MSG_RESULT(no)])
+
# checks for system dependent C++ extensions support
case "$ac_sys_system" in
AIX*) AC_MSG_CHECKING(for genuine AIX C++ extensions support)