summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2010-12-30 14:55:47 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2010-12-30 14:55:47 (GMT)
commitd1fc34d563a9fd06a78226b1bb4e56286c70e035 (patch)
treee71e106006d670ee75334178eb7a6171d9ad831e /configure.in
parent0dbebc02edfb5489248ab42f14f90cf9435e5796 (diff)
downloadcpython-d1fc34d563a9fd06a78226b1bb4e56286c70e035.zip
cpython-d1fc34d563a9fd06a78226b1bb4e56286c70e035.tar.gz
cpython-d1fc34d563a9fd06a78226b1bb4e56286c70e035.tar.bz2
Build and install libpython3.so.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fe030b3..dad37c5 100644
--- a/configure.in
+++ b/configure.in
@@ -608,6 +608,7 @@ AC_MSG_RESULT($LIBRARY)
AC_SUBST(LDLIBRARY)
AC_SUBST(DLLLIBRARY)
AC_SUBST(BLDLIBRARY)
+AC_SUBST(PY3LIBRARY)
AC_SUBST(LDLIBRARYDIR)
AC_SUBST(INSTSONAME)
AC_SUBST(RUNSHARED)
@@ -737,6 +738,10 @@ if test $enable_shared = "yes"; then
BLDLIBRARY='-Wl,-R,$(LIBDIR) -L. -lpython$(LDVERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
INSTSONAME="$LDLIBRARY".$SOVERSION
+ if test $with_pydebug == no
+ then
+ PY3LIBRARY=libpython3.so
+ fi
;;
Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*)
LDLIBRARY='libpython$(LDVERSION).so'
@@ -748,6 +753,11 @@ if test $enable_shared = "yes"; then
;;
esac
INSTSONAME="$LDLIBRARY".$SOVERSION
+ PY3LIBRARY=libpython3.so
+ if test $with_pydebug == no
+ then
+ PY3LIBRARY=libpython3.so
+ fi
;;
hp*|HP*)
case `uname -m` in