summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-02-07 12:04:41 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-02-07 12:04:41 (GMT)
commitd5736816f059e84e1d4bf5a7dd77e88068754479 (patch)
tree46c8da4c130d55cb7efa041b12082246a3cc4827 /configure.in
parent652f4deac938b6a7b0a2f518ed7dcd0011badf1c (diff)
downloadcpython-d5736816f059e84e1d4bf5a7dd77e88068754479.zip
cpython-d5736816f059e84e1d4bf5a7dd77e88068754479.tar.gz
cpython-d5736816f059e84e1d4bf5a7dd77e88068754479.tar.bz2
Merged revisions 78073 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r78073 | ronald.oussoren | 2010-02-07 13:03:42 +0100 (Sun, 07 Feb 2010) | 7 lines * Checks that the SDK specified with --enable-universalsk=VALUE exists. * Fall back to the default system SDK when specifying --enable-universalsk without a value and the 10.4u SDK is not avaiable. Port of fix for issue 4834 from the trunk. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fb86f31..8b03217 100644
--- a/configure.in
+++ b/configure.in
@@ -78,12 +78,17 @@ define_xopen_source=yes
AC_SUBST(CONFIG_ARGS)
CONFIG_ARGS="$ac_configure_args"
+AC_MSG_CHECKING([for --enable-universalsdk])
AC_ARG_ENABLE(universalsdk,
AC_HELP_STRING(--enable-universalsdk@<:@=SDKDIR@:>@, Build against Mac OS X 10.4u SDK (ppc/i386)),
[
case $enableval in
yes)
enableval=/Developer/SDKs/MacOSX10.4u.sdk
+ if test ! -d "${enableval}"
+ then
+ enableval=/
+ fi
;;
esac
case $enableval in
@@ -93,12 +98,23 @@ AC_ARG_ENABLE(universalsdk,
;;
*)
UNIVERSALSDK=$enableval
+ if test ! -d "${UNIVERSALSDK}"
+ then
+ AC_MSG_ERROR([--enable-universalsdk specifies non-existing SDK: ${UNIVERSALSDK}])
+ fi
;;
esac
+
],[
UNIVERSALSDK=
enable_universalsdk=
])
+if test -n "${UNIVERSALSDK}"
+then
+ AC_MSG_RESULT(${UNIVERSALSDK})
+else
+ AC_MSG_RESULT(no)
+fi
AC_SUBST(UNIVERSALSDK)
AC_SUBST(ARCH_RUN_32BIT)