summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:22:03 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-02-11 13:22:03 (GMT)
commitd8244f5cdda1b4111bef3a831e138e7749a2bdd7 (patch)
treef0270a0a4bbe5e3270ded3243028543a1fefede7 /configure.in
parenta3236133d9357d7c8985cb003745255d69cad465 (diff)
downloadcpython-d8244f5cdda1b4111bef3a831e138e7749a2bdd7.zip
cpython-d8244f5cdda1b4111bef3a831e138e7749a2bdd7.tar.gz
cpython-d8244f5cdda1b4111bef3a831e138e7749a2bdd7.tar.bz2
Explicitly call '/usr/bin/arch' instead of just 'arch' to avoid using
a user-installed version of arch instead of the intended version. This is needed because the interface of GNU arch is not quite compatible with what the build machinery expects. Fixes issue #7715 (backport from the trunk)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 01d1b6f..aa9f45d 100644
--- a/configure.in
+++ b/configure.in
@@ -950,15 +950,15 @@ yes)
elif test "$UNIVERSAL_ARCHS" = "all" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch ppc64 -arch x86_64"
- ARCH_RUN_32BIT="arch -i386 -ppc"
+ ARCH_RUN_32BIT="/usr/bin/arch -i386 -ppc"
elif test "$UNIVERSAL_ARCHS" = "intel" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch x86_64"
- ARCH_RUN_32BIT="arch -i386"
+ ARCH_RUN_32BIT="/usr/bin/arch -i386"
elif test "$UNIVERSAL_ARCHS" = "3-way" ; then
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch x86_64"
- ARCH_RUN_32BIT="arch -i386 -ppc"
+ ARCH_RUN_32BIT="/usr/bin/arch -i386 -ppc"
else
AC_MSG_ERROR([proper usage is --with-universal-arch=32-bit|64-bit|all|intel|3-way])