summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2011-11-26 00:11:02 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2011-11-26 00:11:02 (GMT)
commitf0effe637988e936b5a6ece2da789b67723d675c (patch)
treedc6accefaa99f0bda4e6478b729ae3c24f755472 /configure.in
parent61ea8a0d286226ee8b773a01bb2da6b4aa03eb8d (diff)
downloadcpython-f0effe637988e936b5a6ece2da789b67723d675c.zip
cpython-f0effe637988e936b5a6ece2da789b67723d675c.tar.gz
cpython-f0effe637988e936b5a6ece2da789b67723d675c.tar.bz2
Better resolution for issue #11849: Ensure that free()d memory arenas are really released
on POSIX systems supporting anonymous memory mappings. Patch by Charles-François Natali.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 2 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index b41e750..07ec3e2 100644
--- a/configure.in
+++ b/configure.in
@@ -2567,8 +2567,8 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
if_nameindex \
- initgroups kill killpg lchmod lchown lockf linkat lstat lutimes memrchr \
- mbrtowc mkdirat mkfifo \
+ initgroups kill killpg lchmod lchown lockf linkat lstat lutimes mmap \
+ memrchr mbrtowc mkdirat mkfifo \
mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
posix_fallocate posix_fadvise pread \
pthread_init pthread_kill putenv pwrite readlink readlinkat readv realpath renameat \
@@ -2679,15 +2679,6 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
[AC_MSG_RESULT(no)
])
-AC_MSG_CHECKING(whether mallopt can set malloc mmap threshold)
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include <malloc.h>
-]], [[mallopt(M_MMAP_THRESHOLD, 256 * 1024)]])],
- [AC_DEFINE(HAVE_MALLOPT_MMAP_THRESHOLD, 1, Define if mallopt can set malloc mmap threshold.)
- AC_MSG_RESULT(yes)],
- [AC_MSG_RESULT(no)
-])
-
AC_MSG_CHECKING(for broken unsetenv)
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <stdlib.h>