summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-10-31 16:53:53 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-10-31 16:53:53 (GMT)
commitf2d1b2a619e1e4f574d755e324fd0480f4c109a8 (patch)
tree33f6e8f3f274e3e217976623be71fb550d01f421 /configure.in
parent206e10c014e8b61b2c0cb52c797cec63a73c0f8b (diff)
downloadcpython-f2d1b2a619e1e4f574d755e324fd0480f4c109a8.zip
cpython-f2d1b2a619e1e4f574d755e324fd0480f4c109a8.tar.gz
cpython-f2d1b2a619e1e4f574d755e324fd0480f4c109a8.tar.bz2
Merged revisions 86042 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/branches/py3k ........ r86042 | benjamin.peterson | 2010-10-31 11:50:44 -0500 (Sun, 31 Oct 2010) | 1 line add no output to with-system-ffi and with-system-expat ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3a87ff1..8f828de 100644
--- a/configure.in
+++ b/configure.in
@@ -2087,14 +2087,18 @@ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
- AS_HELP_STRING([--with-system-expat], [build pyexpat module using an installed expat library]))
+ AS_HELP_STRING([--with-system-expat], [build pyexpat module using an installed expat library]),
+ [],
+ [with_system_expat="no"])
AC_MSG_RESULT($with_system_expat)
# Check for use of the system libffi library
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
- AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]))
+ AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),
+ [],
+ [with_system_ffi="no"])
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"