summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2000-10-12 17:11:38 (GMT)
committerFred Drake <fdrake@acm.org>2000-10-12 17:11:38 (GMT)
commitf4670e96394bf667f5cd959ee9d282435c792657 (patch)
treec3470fa58637474a2e2f1a779c970213fff876c5 /configure.in
parent22d5895dc337bb457dba6ce3623d835f32f32962 (diff)
downloadcpython-f4670e96394bf667f5cd959ee9d282435c792657.zip
cpython-f4670e96394bf667f5cd959ee9d282435c792657.tar.gz
cpython-f4670e96394bf667f5cd959ee9d282435c792657.tar.bz2
When we know the compiler is GCC, always add the -Wall and
-Wstrict-prototypes options. This will make it a lot easier to keep warnings under control in the first place in the future. There is one known warning at this time, caught by the -Wstrict-prototypes option. In Modules/main.c, the declaration of getopt() without parameters gets a complaint (rightly) that it is not a proper prototype. The lack of a complete prototype information should be corrected when the right portability conditions have been identified. Approved by the Guido.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4d8c11c..3595d70 100644
--- a/configure.in
+++ b/configure.in
@@ -308,8 +308,8 @@ then
case $GCC in
yes)
case $ac_cv_prog_cc_g in
- yes) OPT="-g -O2";;
- *) OPT="-O2";;
+ yes) OPT="-g -O2 -Wall -Wstrict-prototypes";;
+ *) OPT="-O2 -Wall -Wstrict-prototypes";;
esac
;;
*) OPT="-O";;