summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJason Tishler <jason@tishler.net>2003-07-22 15:20:49 (GMT)
committerJason Tishler <jason@tishler.net>2003-07-22 15:20:49 (GMT)
commitfac083d14a94137999559d895a4e6d1d9a2ea74c (patch)
treeae15f57f500e06cd70eaa2996a0eedec3d551d33 /configure.in
parent5d6ceb4aaebc699f30bf26367a15255e4efc2bcd (diff)
downloadcpython-fac083d14a94137999559d895a4e6d1d9a2ea74c.zip
cpython-fac083d14a94137999559d895a4e6d1d9a2ea74c.tar.gz
cpython-fac083d14a94137999559d895a4e6d1d9a2ea74c.tar.bz2
Patch 775605: Cygwin pthread_sigmask() workaround patch
Cygwin's pthread_sigmask() implementation appears to be buggy. This patch works around this problem by using sigprocmask() instead. This patch is implemented in a general way so it could be used by other platforms too. If this approach is deemed too risky, then I can work up a patch that just hacks Python/thread_pthread.h for Cygwin. Note that I tested this patch against 2.3c1 under Red Hat Linux 8.0 too. [snip] And finally, I need someone to regenerate pyconfig.h.in and configure with the same versions of the autotools that are normally used by Python. Neal kindly regenerated pyconfig.h.in and configure for me.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 16a1642..a15a023 100644
--- a/configure.in
+++ b/configure.in
@@ -1701,7 +1701,13 @@ if test "$posix_threads" = "yes"; then
if test "$ac_cv_pthread_system_supported" = "yes"; then
AC_DEFINE(PTHREAD_SYSTEM_SCHED_SUPPORTED, 1, [Defined if PTHREAD_SCOPE_SYSTEM supported.])
fi
- AC_CHECK_FUNCS(pthread_sigmask)
+ AC_CHECK_FUNCS(pthread_sigmask,
+ [case $ac_sys_system in
+ CYGWIN*)
+ AC_DEFINE(HAVE_BROKEN_PTHREAD_SIGMASK, 1,
+ [Define if pthread_sigmask() does not work on your system.])
+ ;;
+ esac])
fi