diff options
author | Ned Deily <nad@python.org> | 2020-05-18 13:17:22 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-05-18 13:17:22 (GMT) |
commit | 0da546665075aefbb476e192ed64122d340164f4 (patch) | |
tree | 7b8ab1370800158880c8bbd210ac36956c768ad7 /setup.py | |
parent | c444108dd62672f2b41539bcc8f15da44501f405 (diff) | |
download | cpython-0da546665075aefbb476e192ed64122d340164f4.zip cpython-0da546665075aefbb476e192ed64122d340164f4.tar.gz cpython-0da546665075aefbb476e192ed64122d340164f4.tar.bz2 |
bpo-26317: Support OBJC and OBJCXX configure command line variables (GH-20176)
Add support to the configure script for OBJC and OBJCXX command line options so that the macOS builds can use the clang compiler for the macOS-specific Objective C source files. This allows third-party compilers, like GNU gcc, to be used to build the rest of the project since some of the Objective C system header files are not compilable by GNU gcc.
Co-authored-by: Jeffrey Kintscher <websurfer@surf2c.net>
Co-authored-by: Terry Jan Reedy <tjreedy@udel.edu>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -1583,10 +1583,11 @@ class PyBuildExt(build_ext): self.missing.append('ossaudiodev') if MACOS: - self.add(Extension('_scproxy', ['_scproxy.c'], + self.add(Extension('_scproxy', [], extra_link_args=[ '-framework', 'SystemConfiguration', - '-framework', 'CoreFoundation'])) + '-framework', 'CoreFoundation'], + extra_objects=['Modules/_scproxy.o'])) def detect_compress_exts(self): # Andrew Kuchling's zlib module. Note that some versions of zlib |