summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2001-01-21 10:54:52 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2001-01-21 10:54:52 (GMT)
commit1ab29b2d3c03886da51af55eb05113d6e4de6b41 (patch)
tree0383d1c0c9373ba0926aa54953533b3981614931 /setup.py
parent6512dbd5be12330bc39a37df8e2bf76e3bd0b1e0 (diff)
downloadcpython-1ab29b2d3c03886da51af55eb05113d6e4de6b41.zip
cpython-1ab29b2d3c03886da51af55eb05113d6e4de6b41.tar.gz
cpython-1ab29b2d3c03886da51af55eb05113d6e4de6b41.tar.bz2
Check for None to decide when pyexpat should not be built.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b18ee18..de9c5b9 100644
--- a/setup.py
+++ b/setup.py
@@ -405,7 +405,7 @@ class PyBuildExt(build_ext):
else:
expat_incs = find_file('xmlparse.h', inc_dirs, [])
- if (expat_incs and
+ if (expat_incs is not None and
self.compiler.find_library_file(lib_dirs, 'expat')):
exts.append( Extension('pyexpat', ['pyexpat.c'],
define_macros = expat_defs,