summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-12-17 08:33:56 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-12-17 08:33:56 (GMT)
commit1c49828fa0b5c479d4f705cb01ee3471e766ac72 (patch)
tree01519cb5a7ad58463936310232f652ecbd75c22b /setup.py
parent9cae178f21745eaa2cbefb74b925bea1322a2baa (diff)
downloadcpython-1c49828fa0b5c479d4f705cb01ee3471e766ac72.zip
cpython-1c49828fa0b5c479d4f705cb01ee3471e766ac72.tar.gz
cpython-1c49828fa0b5c479d4f705cb01ee3471e766ac72.tar.bz2
Add _math.h to math module dependencies in setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6b8ffc4..bad88f7 100644
--- a/setup.py
+++ b/setup.py
@@ -415,6 +415,7 @@ class PyBuildExt(build_ext):
# math library functions, e.g. sin()
exts.append( Extension('math', ['mathmodule.c', '_math.c'],
+ depends=['_math.h'],
libraries=math_libs) )
# fast string operations implemented in C
exts.append( Extension('strop', ['stropmodule.c']) )