diff options
author | Nick Coghlan <ncoghlan@gmail.com> | 2012-06-17 08:27:54 (GMT) |
---|---|---|
committer | Nick Coghlan <ncoghlan@gmail.com> | 2012-06-17 08:27:54 (GMT) |
commit | 2b3eb0dbac9fa3c56176bb9d42b69a97034ccd05 (patch) | |
tree | f39de1ad08b2030e15f2d31c35963110dd88eead /setup.py | |
parent | 71fde31da3d3630b8dc271d3548cba693892509e (diff) | |
parent | 50f147a9be10ee379c4c7bacb81df5e4edf24044 (diff) | |
download | cpython-2b3eb0dbac9fa3c56176bb9d42b69a97034ccd05.zip cpython-2b3eb0dbac9fa3c56176bb9d42b69a97034ccd05.tar.gz cpython-2b3eb0dbac9fa3c56176bb9d42b69a97034ccd05.tar.bz2 |
Merge from 3.2. (Issue #15044: Handle Fedora 17's approach to ndbm compatibility)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -1085,10 +1085,14 @@ class PyBuildExt(build_ext): for cand in dbm_order: if cand == "ndbm": if find_file("ndbm.h", inc_dirs, []) is not None: - # Some systems have -lndbm, others don't + # Some systems have -lndbm, others have -lgdbm_compat, + # others don't have either if self.compiler.find_library_file(lib_dirs, 'ndbm'): ndbm_libs = ['ndbm'] + elif self.compiler.find_library_file(lib_dirs, + 'gdbm_compat'): + ndbm_libs = ['gdbm_compat'] else: ndbm_libs = [] if dbm_setup_debug: print("building dbm using ndbm") |