diff options
author | Victor Stinner <vstinner@python.org> | 2021-10-15 13:21:21 (GMT) |
---|---|---|
committer | GitHub <noreply@github.com> | 2021-10-15 13:21:21 (GMT) |
commit | 354c35220d25a893e502014478f6739dad6897f3 (patch) | |
tree | f9610f948f228ea37c1b5c8a7dd0dc0e2c8f7324 /setup.py | |
parent | a7f8dfd25a167ccfde9996c499fa38a2aba60022 (diff) | |
download | cpython-354c35220d25a893e502014478f6739dad6897f3.zip cpython-354c35220d25a893e502014478f6739dad6897f3.tar.gz cpython-354c35220d25a893e502014478f6739dad6897f3.tar.bz2 |
bpo-45482: Rename namespaceobject.h to pycore_namespace.h (GH-28975)
Rename Include/namespaceobject.h to
Include/internal/pycore_namespace.h.
The _testmultiphase extension is now built with the
Py_BUILD_CORE_MODULE macro defined to access _PyNamespace_Type.
object.c: remove unused "pycore_context.h" include.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -1043,7 +1043,8 @@ class PyBuildExt(build_ext): self.add(Extension('_testimportmultiple', ['_testimportmultiple.c'])) # Test multi-phase extension module init (PEP 489) - self.add(Extension('_testmultiphase', ['_testmultiphase.c'])) + self.add(Extension('_testmultiphase', ['_testmultiphase.c'], + extra_compile_args=['-DPy_BUILD_CORE_MODULE'])) # Fuzz tests. self.add(Extension('_xxtestfuzz', |