summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2001-07-24 06:54:01 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2001-07-24 06:54:01 (GMT)
commit3db5b8cc76d055c6576aaff51722fc4d64d64388 (patch)
tree65e56dfe6ffcd9d66e7f253d6490f8bbcc36945f /setup.py
parent791bfda2b364ec91e5affab2fc0a60ac1701f392 (diff)
downloadcpython-3db5b8cc76d055c6576aaff51722fc4d64d64388.zip
cpython-3db5b8cc76d055c6576aaff51722fc4d64d64388.tar.gz
cpython-3db5b8cc76d055c6576aaff51722fc4d64d64388.tar.bz2
Patch #443669: Permit _tkinter to build on cygwin32.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 7 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 545143a..eab1f59 100644
--- a/setup.py
+++ b/setup.py
@@ -527,8 +527,11 @@ class PyBuildExt(build_ext):
# The _tkinter module.
# Assume we haven't found any of the libraries or include files
+ # The versions with dots are used on Unix, and the versions without
+ # dots on Windows, for detection by cygwin.
tcllib = tklib = tcl_includes = tk_includes = None
- for version in ['8.4', '8.3', '8.2', '8.1', '8.0']:
+ for version in ['8.4', '84', '8.3', '83', '8.2',
+ '82', '8.1', '81', '8.0', '80']:
tklib = self.compiler.find_library_file(lib_dirs,
'tk' + version )
tcllib = self.compiler.find_library_file(lib_dirs,
@@ -586,8 +589,9 @@ class PyBuildExt(build_ext):
if platform in ['aix3', 'aix4']:
libs.append('ld')
- # Finally, link with the X11 libraries
- libs.append('X11')
+ # Finally, link with the X11 libraries (not appropriate on cygwin)
+ if platform != "cygwin":
+ libs.append('X11')
ext = Extension('_tkinter', ['_tkinter.c', 'tkappinit.c'],
define_macros=[('WITH_APPINIT', 1)] + defs,