summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2013-11-24 18:44:57 (GMT)
committerStefan Krah <skrah@bytereef.org>2013-11-24 18:44:57 (GMT)
commit45059eb1d0788aa74ea383c89cf2f8c7a32fd2aa (patch)
treeb3b6d49eaf9541e9c53b0eef260f53e6607b69f0 /setup.py
parentcdac302af362f275f31c13e143f78ec682ef7b68 (diff)
downloadcpython-45059eb1d0788aa74ea383c89cf2f8c7a32fd2aa.zip
cpython-45059eb1d0788aa74ea383c89cf2f8c7a32fd2aa.tar.gz
cpython-45059eb1d0788aa74ea383c89cf2f8c7a32fd2aa.tar.bz2
1) Prepare libmpdec for the 2.4.0 release. None of the following changes affects
_decimal: o Make all "mpd_t to C integer" conversion functions available in both the 64-bit and the 32-bit versions. o Make all mixed mpd_t/C integer arithmetic functions available in the 32-bit version. o Better handling of __STDC_LIMIT_MACROS for C++ users. o Add struct tags (at the request of C++ users). 2) Check for libmpdec.so.2 if --with-system-libmpdec is used.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 19a7b29..9064014 100644
--- a/setup.py
+++ b/setup.py
@@ -1945,7 +1945,7 @@ class PyBuildExt(build_ext):
undef_macros = []
if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
include_dirs = []
- libraries = ['mpdec']
+ libraries = [':libmpdec.so.2']
sources = ['_decimal/_decimal.c']
depends = ['_decimal/docstrings.h']
else: