summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2012-10-06 00:23:36 (GMT)
committerChristian Heimes <christian@cheimes.de>2012-10-06 00:23:36 (GMT)
commit4a0270d82bfd782c89a8ae2b869102dafb81ffea (patch)
tree5bd4262a7a42e94493aa4a0fdf7cdd32185f3a44 /setup.py
parent8c6db45d3e8a20cabe50f93b2bbc33b0040af5a3 (diff)
downloadcpython-4a0270d82bfd782c89a8ae2b869102dafb81ffea.zip
cpython-4a0270d82bfd782c89a8ae2b869102dafb81ffea.tar.gz
cpython-4a0270d82bfd782c89a8ae2b869102dafb81ffea.tar.bz2
Issue #16113: integrade SHA-3 (Keccak) patch from http://hg.python.org/sandbox/cheimes
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4cd3204..b030c4d 100644
--- a/setup.py
+++ b/setup.py
@@ -838,6 +838,15 @@ class PyBuildExt(build_ext):
exts.append( Extension('_sha1', ['sha1module.c'],
depends=['hashlib.h']) )
+ # SHA-3 (Keccak) module
+ sha3_depends = ['hashlib.h']
+ keccak = os.path.join(os.getcwd(), srcdir, 'Modules', '_sha3',
+ 'keccak')
+ for pattern in ('*.c', '*.h', '*.macros'):
+ sha3_depends.extend(glob(os.path.join(keccak, pattern)))
+ exts.append(Extension("_sha3", ["_sha3/sha3module.c"],
+ depends=sha3_depends))
+
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
# your machine, though none are defined by default because of library