summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2012-04-12 17:07:25 (GMT)
committerCharles-François Natali <neologix@free.fr>2012-04-12 17:07:25 (GMT)
commit5739e102ddf62667167da7da878938d64896733d (patch)
tree90bfd02fadcc84c98dc3b2c6306cbe6eb03a862e /setup.py
parente7bade568ebb04c607caf0cfce02a36765dad02e (diff)
downloadcpython-5739e102ddf62667167da7da878938d64896733d.zip
cpython-5739e102ddf62667167da7da878938d64896733d.tar.gz
cpython-5739e102ddf62667167da7da878938d64896733d.tar.bz2
Issue #14557: Fix extensions build on HP-UX. Patch by Adi Roiban.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d69875c..b2829ac 100644
--- a/setup.py
+++ b/setup.py
@@ -467,6 +467,10 @@ class PyBuildExt(build_ext):
if platform in ['osf1', 'unixware7', 'openunix8']:
lib_dirs += ['/usr/ccs/lib']
+ # HP-UX11iv3 keeps files in lib/hpux folders.
+ if platform == 'hp-ux11':
+ lib_dirs += ['/usr/lib/hpux64', '/usr/lib/hpux32']
+
if platform == 'darwin':
# This should work on any unixy platform ;-)
# If the user has bothered specifying additional -I and -L flags