summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Svetlov <andrew.svetlov@gmail.com>2012-12-14 15:04:59 (GMT)
committerAndrew Svetlov <andrew.svetlov@gmail.com>2012-12-14 15:04:59 (GMT)
commit6b2cbeba58aeb0755bdefd02fb51a80ec66d6144 (patch)
tree2634f036965fc3ebf737ef3ce1b830437de9a04f /setup.py
parentf76f0eea5c00ea20ac62d9a8437a19f23fd455c5 (diff)
downloadcpython-6b2cbeba58aeb0755bdefd02fb51a80ec66d6144.zip
cpython-6b2cbeba58aeb0755bdefd02fb51a80ec66d6144.tar.gz
cpython-6b2cbeba58aeb0755bdefd02fb51a80ec66d6144.tar.bz2
Issue #16421: allow to load multiple modules from the same shared object.
Patch by Václav Šmilauer.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c46a2ff..0eca3ec 100644
--- a/setup.py
+++ b/setup.py
@@ -594,6 +594,8 @@ class PyBuildExt(build_ext):
depends=['testcapi_long.h']) )
# Python PEP-3118 (buffer protocol) test module
exts.append( Extension('_testbuffer', ['_testbuffer.c']) )
+ # Test loading multiple modules from one compiled file (http://bugs.python.org/issue16421)
+ exts.append( Extension('_testimportmultiple', ['_testimportmultiple.c']) )
# profiler (_lsprof is for cProfile.py)
exts.append( Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']) )
# static Unicode character database